Protocol for Docking with AutoDock
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Materials

Software:
Linux Machine, Macintosh or Windows PC with Internet access
Text Editor
AutoDock: Download link
AutoDock Vina: [Download Link
AutoDock Tools: [Download Link

Coordinate Files:

. Receptor Protein file, preferably in PDB format. Database of protein PDB

structures is available at: https://www.rcsb.org/

Ligand Coordinate file in pdb, sdf, mol2 format. Various sources are
available for download. For small molecules, sdf files are available from
PubChem.

Supplementary files are available here [1]

Procedure

Coordinate Preparation with AutoDock Tools

Prepare the ligand coordination file with Hydrogens. Open AutoDock
Tools and set the current working directory. If the ligand file does not have
hydrogens, click 'File -> Read Molecule’, select the ligand coordinate file,
and open it. Then click ‘Edit -> Hydrogens -> Add’ to add Hydrogens.

. Next, click ’Ligand -> Input -> Open’ (or 'Ligand -> Input -> Choose’

in case Hydrogens were added in the last step), choose the appropriate file
type, and select and open the ligand coordinate file. AutoDock Tools will
read the coordinate file, add charges if needed, merge non-polar hydrogens


https://autodock.scripps.edu/download-autodock4/
https://vina.scripps.edu/downloads/
https://ccsb.scripps.edu/mgltools/downloads/
https://www.rcsb.org/
https://pubchem.ncbi.nlm.nih.gov/
https://static-content.springer.com/esm/art%3A10.1038%2Fnprot.2016.051/MediaObjects/41596_2016_BFnprot2016051_MOESM457_ESM.zip
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and assign appropriate atom types. Click ok in the pop-up to continue,
and the ligand will be displayed.

Now, select 'Ligand -> Torsion Tree -> Detect Root’; this defines the
centre of the torsion tree. If the torsional degrees of freedom need to be
edited, select 'Ligand -> Torsion Tree -> Choose Torsions’. A window
will open, which will allow making the changes. Rotatable bonds are
displayed in green, rigid bonds in red, and potentially rotatable bonds
are set as 'non-rotatable’ in magenta. In order to toggle between setting
rotational flexibility on and off, click the bonds. When finished, select
"Done’.

After completing the above process, export the processed ligand file as a
PDBQT file by clicking ’Ligand -> Output -> Save as PDBQT’, name
the file appropriately and select ’Save’.

Generate the Receptor coordinate file. Ensure that the file has hydrogen
atoms. Open the molecule in AutoDock Tools by selecting "File -> Read
Molecule’; set the 'Files of Type’ to ’all files’ and open the relevant PDB
file.

Remove waters by selecting "Edit -> Delete Waters’. If the file does not
have Hydrogen positions, select "Edit -> Hydrogens -> Add’, select *All
Hydrogens’, and click Ok’ (ADT will automatically merge non-polar hy-
drogens later).

Now go to ’Grid -> Macromolecule -> Choose’ and select the protein re-
ceptor. AutoDock Tools will add charges, merge non-polar hydrogens and
assign appropriate atom types. Click the Ok’ button to accept changes.
A pop-up will show to save the changes. Name the file appropriately and
save it.

If the Receptor has a metal ion in cofactors (such as Haeme), open the
PDBQT file in a text editor and manually assign the metal ions the correct
charge. The PDBQT file has a format of the following type:

(a) ATOM atom_serial num, atom _name, alt _loc, res_name, chain_id,
res_num, ins_ code, X, y, 2, occupancy, temp_factor, footnote, par-
tial charge, atom type

(b) The second last entry being the partial charge is to be edited.

Make the change in the partial charge and save the file.

Docking Experiment with AutoDock Vina

. The first part involves generating a configuration file to run the Dock-

ing. The configuration file specifies the ligand file, receptor file and other
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docking parameters. Restart AutoDock Tools and set the current work-
ing directory. Click on ’'Grid -> Macromolecules -> Open’ and select
the PDBQT receptor file saved in the last step. Select "Yes’ to preserve
previous changes, and then press 'Ok’ to accept the changes.

2. We need to define the Grid Box, which defines the search space. Select
'Grid -> Set Map Types -> Open Ligand’ and open the saved ligand
PDBQT file. Next, go to 'Gird -> Grid Box’, which opens a window
allowing you to define the box. In case the probable binding site of the
ligand is known, use the ligand to centre the grid box by choosing ’Center
-> Center on Ligand’. The grid box can similarly be centred around a
particular region using rotating knobs. If the Docking is being done blindly
(running the Docking all over the enzyme), enclose the enzyme in the grid
box.

3. When the above step has been completed, choose ’File -> Close Saving
Current’ in the window. Next, go to 'Docking -> Output -> Vina Config’
and save the configuration file by naming it and clicking "Save’.

4. Run AutoDock Vina from the command line. Add Vina to the folder
containing all the PDBQT and config files. Exhaustiveness needs to be
given, which defines the amount of computational effort to find the binding
site (essentially, how exhaustive the search is. Higher is better). The
default value is 8; however, higher values like 24 and 32 give more reliable
results.

5. To run the Docking, use the command
./vina --config config.txt --log log.txt ---exhaustiveness=32

6. The above command will generate an output file with the name ligand _out.pdbqt.
In addition, information about the docking poses and the affinities will be
displayed on the command line. The same will be saved in a document
called log.txt.

7. To visualise the Docking, open the AutoDock Tools and set the current
working directory. Select ’Analyse -> Dockings -> Open AutoDock Vina
Results’ and choose the output file generated. Select the option of ’Sin-
gle Molecule with Multiple Conformations’ in the pop-up that appears
and click '’Ok’. This will show a single molecule for which the different
conformations can be toggled by using arrow keys. Click ‘Analyze ->
Macromolecule -> Open’ to choose the receptor molecule. If the crystal-
lographic ligand coordinate file exists, it can also be loaded from ’File ->
Read Molecule’ and the docking poses can be compared to the crystal-
lographic position. To view interactions, ‘Analyze -> Dockings -> Show
Interactions’ can be used.

8. Other than AutoDock Tools, UCSF Chimera and Pymol are other software
which are very useful for viewing Docking poses, along with hydrophobic
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and electrostatic mapping of the Receptor and ligand. A different software
of choice can be used after performing Docking for visualisation.

Active Site Prediction using AutoLigand

. AutoLigand is a part of AutoDock tools and is helpful in identifying the

optimal regions for ligand binding by analysing AutoGrid interaction en-
ergy maps for three atom types (C, OA and HD) and the electrostatics
and desolvation maps calculated with 1 A grid spacing.

Start AutoDock Tools, and set the current working directory. In 'Grid ->
Macromolecules’, select the coordinate file for the Receptor. In ’Grid ->
Set Map Types -> Directly’, edit the atom list to be ’C HD OA’.

In ’Grid -> Grid Box’, set the spacing to 1A and adjust the Grid Box
to contain the whole protein. Save the parameters using 'File -> Close
Saving Current’, and write the grid parameter file with 'Grid -> Output
-> Save GPF’ with the name of the Receptor. Run AutoGrid on the com-
mand line (make sure the AutoGrid is in the directory containing the files)
./autogrid4 -p [receptor_name].gpf -1 [receptor_name].glg

Load AutoLigand on AutoDock tools by going to 'File -> Browse Com-
mands’. Next, in ’Select Package’, select ’AutoDock Tools’; in ’Select a
Module’; select ’AutoLigand Command’; click 'Load Select Module’ and
then click 'Ok’.

v. Select 'File -> Read Molecule’ and read the Receptor PDBQT file
and then select ’File -> Read Molecule’ and read the ligand PDBQT file.
Start AutoLigand Computation by choosing ‘Compute -> AutoLigand ->
Run AutoLigand’. This will open a window to choose the seed point and
envelope size. Use the sliders to place the yellow seed point near the active
site, or shift-click an atom to place the marker. Use the default value of
100 for Envelope Volume. Start the computation by clicking ok. When
Autoigand finishes, a pop-up will open displaying the results, and the
envelope will be saved as a PDB file and will be displayed in the viewer.

vi. Alternatively, AutoLigand can also be run from the command line
(Which does not require seeding the active site) by using the command:
python [PATH]AutoLigand.py [Receptor] [Fill points]

and open the resulting files into AutoDock tools to visualise.

Docking with Explicit Waters

. This method adds dummy atoms to the ligand that correspond to all

possible hydration sites. A modified AutoGrid map is then used during
Docking, giving a favourable score when the water is well placed and
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omitting it if it overlaps with the Receptor. A final script analyses the
docked results, retaining only those waters in appropriate positions.

2. Prepare the Ligand and Receptor files for standard AutoDock Docking.
Add all the required supplementary files to the common directory. Run the
command python wet.py -i ligand.pdbqt
This adds dummy ‘W* atoms to the ligand PDBQT file and saves it to
ligand  HYDRO.pdbqt.

3. Calculate the default atomic grid maps. Start ADT and set the default
working directory. Select 'Ligand — Input — Open’ and choose the lig-
and PDBQT file and select ’Grid — Macromolecule — Open’ and choose
the receptor PDBQT file. Set the map types in 'Grid — SetMapTypes
— Directly’ and ensure that the "THD’ and ’OA’ types are in the list. Use
"Grid — GridBox’ to specify the centre and size of the search space. Use
"Center — Center on Ligand’ in the pop-up window to define a minimal
box. When finished, save the parameters using 'File — Close Saving Cur-
rent’. Write the grid parameter file using ’Output — SaveGPF’ with the
name ’protein.gpf.” Run AutoGrid with 'Run — RunAutoGrid’ or at the
command line with
./autogrid4 -p protein.gpf -1 protein.glg

4. Generate the "W’ map. If standard filenames are used for the maps, only
the receptor name must be specified for the script that generates the map
for the water-energy evaluation:
python mapwater.py -r protein.pdbqt -s protein.W.map

5. Create a modified docking parameter file. Select 'Docking — Macro-
molecule — Set Rigid File name’ and choose the receptor PDBQ. Select
'Docking — Ligand — Choose’ and choose the ligand PDBQT file (lig-
and_ HYDRO.pdbqt), and accept the default ligand docking parameters,
which will randomise the pose of the ligand before Docking. Set the search
parameters in 'Docking — SearchParameters — Genetic Algorithm Pa-
rameters’, changing 'Number of GA Runs’ to 50, and use defaults on the
remaining parameters. In ’Docking — DockingParameters’, use default
parameters for most small ligands.

6. Write the docking parameter file using 'Docking — Output — Lamarckian
GA’, with the name ’ligand  HYDRO _protein.dpf’.

7. The standard docking parameter file must be modified manually in two
ways: 'parameter file AD4 water forcefield.dat’ must be added near the
top, and ’protein.W.map’ must be added to the list of maps. Both of these
changes are highlighted.

8. Run AutoDock in ADT with 'Run — Run AutoDock’ or at the command
line with
./autodock4 -p ligand_HYDRO_protein.dpf -1 ligand HYDRO_protein.dlg
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9. Extract and score the results at the command line with
python dry.py -c -r protein.pdbqt -m protein.W.map -i ligand_HYDRO_protein.dlg

10. This script will filter the docking results using the Receptor to identify
displaced water and the W map to rank the conserved ones as strong or
weak. This will write a file called ligand LELC DRY SCORED.pdbqt
with the calculated energy.
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